Page 1 of 1

NFS versions that work on WinXP - I'm confused

PostPosted: 28 Jun 2006, 09:07
by Jamaleni
As we all know NFS IV and V don't work (well/as they are supposed to) on Windows XP, but yesterday I discover something strange....

I have one old laptop (P III 800, 512 MB RAM, onboard graphic) and I decided to prepare it for going on vacation and install some games on it. As I knew that it is too weak for any NFS above version III, I simply put the NFS III CD in drive and install it. When I was going to try is it working, I remembered above mentioned problem with WinXP and allmost start uninstall, but then I said well what the heck, I'll try it when I install it, and IT WORKS, not just that but then I tried NFS II SE and it works too....

So why then NFS IV don't work on WinXP???????

PostPosted: 28 Jun 2006, 12:01
by Andre_online
Try finding a solution here maybe? ;)

PostPosted: 28 Jun 2006, 16:46
by 2furio
His question is not how to make HS run on XP, it's why does NFS3: HP and NFS II work without problems while HS doesn't work without problems.

PostPosted: 28 Jun 2006, 17:19
by SP4RCO
Ehrm, if Im not wrong Microsoft updated something in SP1 to make certain programs compatible with their operating system. NFS III was among those programs, NFS IV/V not.

Microsoft's fault. Go to their forums and roll on them for me :P

PostPosted: 29 Jun 2006, 09:33
by RazoR_MKD
How could that be,dumb billy gates :)

PostPosted: 29 Jun 2006, 12:44
by Andre_online
2furio wrote:His question is not how to make HS run on XP, it's why does NFS3: HP and NFS II work without problems while HS doesn't work without problems.

I'm sorry.. Didn't quite get you here.

PostPosted: 30 Jun 2006, 00:05
by xHaZxMaTx
He's saying HP anf NFS II work, but HS doesn't. :roll:

older need for speed games

PostPosted: 01 Jul 2006, 22:51
by hugh750
NFS IV and V might work in xp if ran them under compatilty mode. :wink:

PostPosted: 02 Jul 2006, 00:08
by Stereo
Run them in compability mode on windows XP. Windows 2000 or 98 compabilty...

PostPosted: 02 Jul 2006, 01:05
by xturbo
that doesn't work for me stereo, did you have any other solutions, my friend??

PostPosted: 04 Jul 2006, 09:31
by Jamaleni
Stereo wrote:Run them in compability mode on windows XP. Windows 2000 or 98 compabilty...


Tried, don't work :(

PostPosted: 04 Jul 2006, 13:51
by Andre_online
I manage to run NFSHS on my current XP. I think mine's under SP2. It's running perfectly, except for some occassional errors popping out after installing cars. It's pretty normal for me. :P