Page 1 of 1

NFSP2000/NFSPU doesn't work in WinXP

PostPosted: 27 Jul 2005, 11:52
by Modulator
Hello!

My original NFSP2000/NFSPU doesn't work on my WinXP computer. I tried some of the tips on the forum. I even patched it to 3.5. It keeps prompting "3d graphics hardware could not be initialized".... I don't understand whats wrong. :( :( :evil: :evil: :cry:

PostPosted: 27 Jul 2005, 12:15
by prince1142003
you need to install the latest version of directX.... and the latest drivers for your graphics card.

for directX, go to Start and click on Run. type in dxdiag and press Enter. if your directX version is anythying beloe 9.0c, go to http://www.microsoft.com and download directX 9.0c

as for the latest drivers for your graphcis card, go to the website of the maker, and download the latest drivers there. you can find out what kind of graphics card you have by right-clicking on your desktop, and clicking on properties. then go to settings and click on advanced. go to adapter, and that's your graphics card

hope that helped somewhat

PostPosted: 27 Jul 2005, 12:26
by Modulator
I have the latest version of DirectX. And graphic drivers too. But when I run the DXDIAG it says on the DirectX 7 that there is memory too low. Everything else is allright. My graphics card is Club3d Radeon 9600 Pro 128mt.

PostPosted: 27 Jul 2005, 12:55
by prince1142003
could you explain the error you get when you run DXDIAG? you said you get a memory too low error. could you elaborate how you get this error (what you do, if u even have to do enything)

also, post system specs. like processor speed, amt ram, all that jazz....

try running the 3d setup program Start -> Programs -> Electronic Arts -> Need for Speed Porsche Unleashed (assuming u didnt change this during install).... see what errors it gives you

PostPosted: 27 Jul 2005, 13:16
by Modulator
Well im on Finland and its Finnish version of dxdiag so i try to translate it. Well it says on the error: Error on testsession 8 (Creating 3d-machine) HRESULT = 0x8007000e (Memory is low). Well its something like that. My system specs:

Intel Pentium 4HT 2,60Ghz
512mt memory
120gt hard drive
Radeon 9600 Pro 128mt (Club3d)

I also tried to run the 3dsetup but it doesn't work (dont appear to display).

:?: :?: :?: :?: :?: :?: :?: :?: :?: :evil: :evil: :evil: :( :( :(

PostPosted: 27 Jul 2005, 13:20
by Modulator
I didn't try to do anything....

PostPosted: 27 Jul 2005, 13:26
by Andre_online
Have you tried searching for the solution in <a href="http://forum.nfsunlimited.net/viewtopic.php?t=28">this</a> topic? :P

PostPosted: 27 Jul 2005, 13:29
by Modulator
Yes i did but there is no solution for this problem.

PostPosted: 27 Jul 2005, 13:34
by Modulator
Could the problem be that the DXDIAG doesn't display anything on the All memory- section. The is only a line.

PostPosted: 27 Jul 2005, 13:45
by ^Sparco^
I dont have any problem...

I'm running it on XP + Service Pack 2.
Gforce FX5200.
P4 2.8Ghz

etc.

Do you have the Sevgice Pack 2?

PostPosted: 27 Jul 2005, 13:49
by Modulator
Yes i have.

PostPosted: 27 Jul 2005, 13:57
by prince1142003
i dont seem to have a memory section in my dxdiag..... odd....

if you have any other 3d games, do they run?

PostPosted: 27 Jul 2005, 14:00
by Modulator
Yes they do.

prince: That memory thing is on display section.

PostPosted: 27 Jul 2005, 14:21
by Modulator
Should i abandon this game or continue looking solutions... I like this game and its one of my favourites. Those tips wont work to me....

PostPosted: 27 Jul 2005, 15:06
by prince1142003
hey, don't double post, ok? see the edit button? yes... that's Mr. Edit Button.he's your friend. yes he is... click Mr. Edit Button if you want to edit your posts... awwww, he wuvs you

honestly, i dont know what could be wrong here.... you could do a fresh install of DirectX, Graphics Card drivers, and NFSPU to see if the problem persists....

since most games do use DirectX and others seem to work on yuor system, i dont think the problem lies with either DirectX or your graphics card.... so i'd reinstall NFSPU first, and then go from there....

PostPosted: 27 Jul 2005, 18:52
by SuperRacer
Have you tried lowering your page file size like it says in the sticky? Your 512mb RAM could be causing problems.

NFSP2000/NFSPU doesnt work in WinXP

PostPosted: 17 Nov 2017, 15:57
by VawArrarty
Ah I get you, tbh it doesnt say on any system settings so im unsure how to find out. I only have one HDMI port and no dedicated graphics card as far as I am aware. Is the PC just not up to it or is there things I can do to help it run better?